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Übung 4: Coot1

Thema der heutigen Übung ist die Bestimmung von Proteinstrukturen aus Daten eines

Röntgen-Kristallographie-Experiments. Dazu werden wir uns dem folgendem Beispiel

zuwenden:  Gegeben  ist  eine  Proteinstruktur  und  eine  mit  dieser  überlagerte

Elektronendichtekarte.  Verglichen  mit  der  gegebenen  Proteinstruktur  enthält  das

Protein, von dem die Elektronendichtekarte stammt, allerdings einige Mutationen und

Sie sollen herausfinden, welche das sind.

Zu Hilfe nehmen wir die unter Kristallographen sehr beliebte Software Coot. Ähnlich

wie  Chimera ist  Coot (Crystallographic  Object-Oriented  Toolkit)  ein Programm zur

interaktiven  Darstellung  und  Manipulation  von  Makromolekülen  (Proteine,

Nukleinsäuren,  …).  Der  Fokus  liegt  hier  allerdings  auf  der  Erstellung  und  der

Überprüfung  von  3D-Strukturen  anhand  kristallographisch  ermittelter  Elektronen-

dichtekarten.  

1 Geschrieben von Björn Hansen. Vielen Dank an Markus Perbandt für seine Hilfestellungen bei der 

Konzeption dieser Übung.
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1 Einführung für   Coot  -Neulinge  

Zu Beginn dieser Übung möchten wir Sie mit  Coot vertraut machen. Die Aufgaben-

zusammenstellung im ersten Teil dieser Übung ist eng an das  Coot-Tutorial von der

offiziellen Coot-Website2 angelehnt.

Starten von Coot:

Geben Sie 

/home/petersen/programs/coot-Linux-x86_64-red-hat-gtk2-python/bin/coot &

in die Kommandozeile Ihrer Shell ein, um Coot zu starten.

Anschließend wird sich das Hauptfenster von Coot öffnen:

Öffnen von Strukturen und Elektronendichtekarten:

Wählen Sie 

File -> Open Coordinates… 

in der Coot-Menüleiste aus und klicken Sie im sich öffnenden Fenster auf „File 

System“.

2 http://www2.mrc-lmb.cam.ac.uk/Personal/pemsley/coot/
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Wechseln Sie dann in das Verzeichnis 
/home/petersen/teaching/crystallography und wählen Sie hier die Datei 

tutorial-modern.pdb aus. Bestätigen Sie Ihre Auswahl mit „Open“. Im sich 

öffnenden Fenster „Fix Nomenclature Errors“ wählen Sie „Yes“.

Anzeige der Elektronendichtekarten

Wählen Sie 

File -> Auto Open MTZ… 
in der Coot-Menüleiste und anschließend rnasa-1.8-all_refmac1.mtz aus.

Eine mtz-Datei enthält unter anderem die Amplituden der Strukturfaktoren und die

Phaseninformationen.  Mit  Hilfe  der  in  der  Vorlesung  vorgestellten  Fourier-

Transformation  kann  aus  diesen  Informationen  die  in  blau  dargestellte  „normale“

Elektronendichtekarte berechnet werden. Zusätzlich sehen Sie noch rote und grüne

Bereiche. Diese stammen von einer so genannten Differenzelektronendichtekarte, die

uns  dabei  hilft,  Fehler  im  Modell  zu  erkennen.  Grün  sind  die  Bereiche  positiver

Differenzdichte. Sie zeigen uns, dass hier das Strukturmodell noch unvollständig ist.

Die roten Bereiche dagegen weisen eine negative Differenzelektronendichte auf. An

diesen Stellen verfügt das Modell über fehlerhaft platzierte Atome.

Bedienung:

Mit Maus und Tastatur ist es möglich, eine geöffnete Struktur in Coot zu bewegen und

einzelne  Elemente  innerhalb  dieser  Struktur  auswählen.  Die  Bedienung ist  hierbei

relativ ähnlich, wenn auch nicht gleich zu dem, was Sie aus Chimera gewohnt sind.

Wenden Sie die folgenden Aktionen nacheinander an, um sich mit der Bedienung von 

Coot vertraut zu machen:

- Bewegen Sie die Maus mit gedrückter linker Maustaste, um die geöffnete 

Struktur zu rotieren.

- Bewegen Sie die Maus mit gedrückter linker Maustaste UND gleichzeitig die Ctrl-

Taste, um die geöffnete Struktur zu verschieben.

- Wählen Sie, während Sie die Shift-Taste gedrückt halten, Atome mit der linken 

Maustaste aus, um sie zu beschriften.

- Bewegen Sie die Maus mit gedrückter rechter Maustaste, um in die 

Darstellungsebene hinein bzw. aus ihr heraus zu zoomen. 
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- Klicken Sie ein Atom mit der mittleren Maustaste (das Mausrad) an, um dieses 

Atom ins Zentrum der Darstellungsebene zu rücken.

- Drehen Sie am Mausrad (vorwärts oder rückwärts), um das Konturlevel3 der 

Elektronendichtekarte zu modifizieren (vergrößern oder verkleinern). 

Alternative: Nutzen Sie die Tasten „+“ und „-" (nicht die auf dem Num-Block).

Im Display-Manager

Draw -> Display Manager

können Sie über die Scroll-Radiobuttons

festlegen, für welche der geöffneten

Elektronendichtekarten Sie beim Drehen

des Mausrades den Konturlevel verändern

möchten. 

  

Entlangwandern der Proteinkette

Im Fenster “Go To Atom” 

Draw -> Go To Atom…

können Sie unten links in der Liste auf

den Pfeil vor „Chain A“ klicken, um die

einzelnen Restgruppen der Kette A

anzuzeigen (siehe Abbildung rechts).

Wählen Sie „1 ASP“ aus und bestätigen

Sie Ihre Auswahl mit „Apply“.

Über die Buttons „Next Residue“ und

„Previous Residue“ können Sie von

Restgruppe zu Restgruppe die Proteinkette entlang wandern. Wenn das Fenster „Go To

Atom…“ geschlossen ist, können Sie hierfür alternativ auch Leertaste (vorwärts) und 

Shift+Leertaste (rückwärts) verwenden.

3 In unserer Elektronendichtekarte gibt es nicht Orte mit und ohne Elektronendichte, es gibt nur Orte

unterschiedlich hoher Elektronendichte. Wir können einen Schwellwert (das Konturlevel) auswählen,

anhand dessen der Raum in Orte hoher und niedriger Elektronendichte eingeteilt wird. Zur grafischen

Veranschaulichung  wird  die  Oberfläche  eingezeichnet,  die  diese  beiden  Bereiche  des  Raumes

voneinander  trennt.  Auf  dieser  Oberfläche  entspricht  die  Elektronendichte  genau  dem gewählten

Schwellwert.
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Farbe der Elektronendichtekarte ändern

Wählen Sie im Coot-Hauptmenü

Edit -> Map Colour… -> Elektronendichtekarte Ihrer Wahl

Wählen Sie eine neue Farbe aus und bestätigen Sie Ihre Auswahl mit „OK“.

Modelbau

Sie werden sich vielleicht fragen, was mit der geöffneten Struktur nicht stimmt.

Es gibt viele verschiedene Analysemöglichkeiten dafür, Fehler und Ungenauigkeiten in

einer gegeben Struktur (Protein, DNA, RNA, …) ausfindig zu machen und einige von

diesen sind in Coot verfügbar. 

Wählen Sie 

Validate -> Density Fit Analysis -> tutorial-modern.pdb

über die Coot-Menüleiste.

Anschließend wird Coot Ihnen ein Histogramm anzeigen: 

Schauen  Sie  sich  das  Histogramm  an:  Je  größer  und  roter  ein  Balken  ist,  desto

schlechter ist die Geometrie des Proteins in diesem Bereich. Besonders negativ fallen

die Bereiche in der A-Kette an den Aminosäure-Positionen 41 und 89 auf. 

Lassen Sie uns zunächst einen Blick auf den Rest 89 (A-Kette) werfen. Klicken Sie

hierzu im Histogramm auf den entsprechenden Balken. Coot wird jetzt das Cα-Atom

des Restes 89A ins Zentrum der Ansicht setzen.
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Wie Sie sehen, zeigt die Restgruppe dieses Phenylalanin-Restes in die falsche Richtung.

Diesen  Fehler  wollen  wir  jetzt  beheben.  Lassen  Sie  sich  hierfür  zunächst  das

„Model/Fit/Refine“-Fenster anzeigen

Calculate -> Model/Fit/Refine

und wählen Sie hier „Rotamers…“ aus. 

 

Im  Coot-Hauptfenster  können  Sie  jetzt  mit  der  linken

Maustaste eines der Atome des Restes 89A (z.B. das Cγ-Atom)

auswählen. Es erscheint dann das „Select Rotamer“-Fenster.

Wählen  Sie  hier  dasjenige  Rotamer  aus,  bei  welchem  die

Atome am besten zur Elektronendichte der Seitekette passen.

Bestätigen Sie Ihre Auswahl mit „OK“. 

Die Koordinaten der Restgruppe passen allerdings noch immer

nicht perfekt zur Elektronendichte. Wählen Sie jetzt im noch

geöffneten „Model/Fit/Refine“-Fenster die Option „Real Space

Refine Zone“ aus und klicken Sie anschließend zweimal auf ein

Atom  des  Restes  89A.  Wählen  Sie  in  dem  sich  öffnenden

„Accept  Refinement?“-Fenster  „Accept“.  Nun  passen

Elektronendichte  und Koordinaten  der  Restgruppe  an  dieser

Position perfekt zusammen. 

Ob es auch möglich ist, nur „Real Space Refine Zone“ zu verwenden? 

Wählen Sie im „Model/Fit/Refine“-Fenster zweimal  „Undo“, um die ursprünglichen

Koordinaten der Restgruppe wiederherzustellen. Wählen Sie im selben Fenster erneut

„Real Space Refine Zone“ aus und klicken Sie ein Atom der Restgruppe zweimal an. 

Es  wird  nun  ein  neues  „Accept  Refinement?“-Fenster  angezeigt  und  in  grau  ein

Vorschlag  für  eine  neue  Positionierung  dieses  Phenylalanin-Restes.  Mit  diesem

Vorschlag sind wir allerdings noch nicht zufrieden. Klicken Sie deshalb jetzt mit der

linken Maustaste eines der Atome des Neupositionierungsvorschlags für Rest 89A an,

ziehen Sie dann das Atom mit gedrückter linker Maustaste in den Bereich der hohen

Elektronendichte (drag) und lassen Sie anschließend die linke Maustaste los (drop). 

Es ist auch möglich, ein einzelnes Atom zu bewegen. Drücken Sie hierfür gleichzeitig

noch die Ctrl-Taste. Wählen Sie „Accept“ im „Accept Refinement?“-Fenster, sobald

Sie mit der Strukturverbesserung zufrieden sind. 
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Weitere Strukturverbesserungen

Wir  wollen  uns  nun  die  andere  Region  ansehen,  in  der  es  besonders  auffällige

Unterschiede zwischen Proteinstruktur und Elektronendichtekarte gibt. Klicken Sie im

Fenster „Density Fit Graph“ im Histogramm auf den roten Balken für Rest 41A.

Was fällt Ihnen auf? Versuchen Sie wie im vorherigen Beispiel mit der Option „Real

Space Refine Zone“ das Problem zu lösen.

„Kleckse“ in der Elektronendichtekarte

In  der  Elektronendichtekarte  gibt  es  einige  Bereiche  mit  deutlich  sichtbarer

Elektronendichte (grün), denen aber kein Teilbereich der Struktur zugeordnet wurde.

Wählen Sie 

Validate -> Unmodelled Blobs

im Coot-Hauptmenü, um diese Kleckse (Blobs) in der Elektronendichtekarte zu finden.

Im Fenster „Find Unmodelled Blobs of density“ wählen Sie unter „Select Map“ Option

1  (FWT  PHWT)  aus  und  klicken  anschließend  auf  „Find  Blobs“.  In  der  darauf

erscheinenden Liste wählen Sie zunächst Blob 2 aus.

Blob 2

Schauen Sie sich die Situation genau an. Was fällt Ihnen auf?

Offensichtlich  brauchen  wir  hier  ein  tetraedisches  Molekül.  Klicken  Sie  im

„Model/Fit/Refine“-Fenster auf den Button „Place Atom At Pointer“ und wählen Sie

SO4 aus.

Wie Sie sehen, wurde ein Sulfat-Anion in „Blob 2“ platziert,  allerdings  noch nicht

optimal. Verwenden Sie erneut die Option „Real Space Refine Zone“, um die Position

des SO4-Moleküls genau an die Elektronendichtekarte anzupassen. 

Blob 1

Schauen Sie sich die Elektronendichte in diesem Bereich genau an. Was fehlt Ihrer

Meinung nach? 

Wenn Sie vermuten, dass hier ein paar Aminosäurereste am C-terminalen Ende der

Kette A fehlen, liegen Sie goldrichtig. Die fehlenden Reste sind Glutamin, Threonin

und Cystein. Wir wollen diese nun ergänzen: 

Calculate -> Fit Loop… 

In dem sich öffnenden Fenster „Mutate Sequence“ tragen Sie „Residue numbers 94 to 

96“ für Kette A ein und „QTC“ als „single letter sequence“ (siehe nächste Seite).
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Stellen  Sie sicher,  dass  Sie den unmodellierten Teil  der  Elektronendichtekarte gut

sehen können und bestätigen Sie anschließend Ihre Eingaben durch Klicken auf „Fit

Loop“.

An  der  Carboxylgruppe  am  C-terminalen  Ende  (Cystein;  A96)  fehlt  noch  ein

Sauerstoffatom, welches wir ergänzen wollen: 

Calculate  Other Modelling Tools…

Wählen Sie im sich öffnenden Fenster „Add OXT to Residue…“ aus und ergänzen Sie 

das fehlende Sauerstoff-Atom. 

Nutzen Sie wieder die Option „Real Space Refine Zone“, um die Positionierung der 

hinzugefügten Restgruppen zu optimieren, falls dies erforderlich ist. 

Zu welchem Cysteinrest wird das Cystein 96 vermutlich eine Disulfidbrücke ausbilden? 

Notieren Sie Ihre Antwort auf der letzten Seite dieser Übung.

Hinzufügen endständiger Restgruppen

Verwenden Sie das Fenster „Go To Atom…“ um zum Rest 72 der Kette A zu gelangen 

und schauen Sie sich diesen Bereich genau an. Ihnen wird auffallen, dass hier einige 

Atome fehlen. Eigentlich sollte an dieser Stelle ein Cystein-Rest sein. Lassen Sie uns 

diese Restgruppe zunächst entfernen. Klicken Sie hierzu im Fenser „Model/Fit/Refine“

auf „Delete“. Im sich öffnenden Fenster „Delete item“ wählen Sie dann 

8



„Residue/Monomer“ aus und klicken danach ein Atom des Restes 72A an. Diese 

Aminosäure wird daraufhin verschwinden. 

Als  nächstes  wollen  wir  an  dieser  Stelle  ein  Alanin  einfügen.  Wählen  Sie  im

„Model/Fit/Refine“-Fenster die Option „Add Terminal Residue“ aus und klicken Sie

dann ein Atom des benachbarten Restes (71A) an. Coot wird jetzt einen Alanin-Rest im

gewünschten Bereich der Elektronendichtekarte platzieren. Klicken Sie auf „Accept“,

um diese Änderung anzunehmen. 

Der Alanin-Rest wurde nun ergänzt, aber eigentlich gehört ein Cystein an diese Stelle.

Wählen Sie die Option „Mutate & Auto Fit…“ aus und klicken Sie dann auf ein Atom des

neu hinzugefügten Alanin-Restes. In der daraufhin erscheinenden Auswahl wählen Sie

„CYS (C)“ aus. 

Betrachten Sie den Bereich, in welchem die Cystein-Restgruppe platziert wurde, etwas

genauer.  Ihnen  wird  auffallen,  dass  es  hier  zwei  Bereiche  mit  erhöhter

Elektronendichte  gibt,  in  denen  die  Cystein-Restgruppe  Platz  finden  würde.  Zu

erklären  ist  dies  damit,  dass  es  für  diesen  Cystein-Rest  zwei  alternative

Konformationen gibt. Lassen Sie uns dies modellieren:

Klicken Sie auf „Add Alt Conf“ und danach auf ein Atom des Reste 72A. Wählen Sie

anschließend in der sich öffnenden Auswahl das passende Rotamer aus und bestätigen

Sie Ihre Auswahl mit „OK“. Ihnen werden jetzt zwei Cysteinreste angezeigt. Nutzen

Sie wieder die Option „Real Space Refine Zone“, um die Positionierung zu optimieren.

Sie sind jetzt gut genug vorbereitet, um mit dem zweiten Teil dieser Übung zu 

beginnen. Schließen Sie jetzt Struktur und Elektronendichtekarte:

File -> Close molecule/map…

Anschließend wählen Sie alle geöffneten Strukturen und Maps aus und klicken auf 

„Delete Marked Molecules & Maps“.
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2 Modellkorrektur

Wie  bereits  zu  Beginn  beschrieben,  wird  Ihre  Aufgabe  nun  darin  bestehen,  ein

gegebenes Proteinstrukturmodell anhand einer Elektronendichtekarte zu korrigieren.
Öffnen  Sie  bitte  zunächst  das  Modell  exercise_model_refmac1.pdb und  die

zugehörige Elektronendichtekarte  exercise_data_refmac1.mtz. Sie finden diese

Dateien im Verzeichnis /home/petersen/teaching/Crystallography.

Starten Sie Ihre Arbeit beim ersten Rest des gegebenen Proteins:

Draw -> Go To Atom…

Wie Sie deutlich  beim Vergleich  zwischen Modell  und Elektronendichtekarte sehen

können, ist das Modell an dieser Stelle unvollständig. Die Elektronendichtekarte im

Bereich der ersten Restgruppe enthält einen größeren Abschnitt, der nicht durch die

Restgruppe der Aminosäure Alanin, eine Methylgruppe, ausgefüllt  wird. Wir  wollen

deshalb Alanin gegen eine andere Aminosäure austauschen. 

Quelle: www.wikimedia.org
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Welche  Aminosäure  würden  Sie  vorschlagen?  Welche  können  Sie  in  jedem  Fall

ausschließen?  Falls  Sie  keinen  biologischen/biochemischen  Hintergrund  haben  und

daher mit den verschiedenen Restgruppen der Aminosäuren noch nicht sehr vertraut

sind, dürfen Sie gerne die Übersicht auf der vorherigen Seite zur Hilfe nehmen.

Rufen Sie sich erneut das Fenster „Model/Fit/Refine“ auf

Calculate -> Model/Fit/Refine…,

klicken Sie anschließend auf „Mutate & Auto Fit“ und danach auf ein Atom des Alanin-

Restes an Position 1. Wählen Sie aus der erscheinenden Liste „LYS (K)“ aus, um den

Alanin-Rest gegen Lysin auszutauschen. 

Wie Sie sehen, passt die Restgruppe des Lysin-Restes perfekt zur Elektronendichte an

dieser Position. 

Durch Drücken der Leertaste gelangen Sie zur nächsten Aminosäure, ein Valin. Hier

scheint alles in Ordnung zu sein. Drücken Sie die Leertaste ein weiteres Mal.

An Position 3 des Modells befindet sich ein Alanin. Anhand der Elektronendichte in

diesem Bereich können Sie aber eindeutig sehen, dass Alanin an dieser Position nicht

die richtige Aminosäure ist. Welche Aminosäure würden Sie vorschlagen?

Gehen Sie jetzt Schritt für Schritt die gesamte Proteinsequenz entlang. Finden Sie alle

Mutationen  und  korrigieren  Sie  das  Modell  entsprechend.  Notieren  Sie  Ihre

Mutationsvorschläge in der Tabelle auf der folgenden Seite.
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3 Aufgaben

a) Zu welchem Cysteinrest wird das Cystein 96 (Abschnitt: 1 Einführung für Coot-

Neulinge) vermutlich eine Disulfidbrücke ausbilden?

b) Füllen Sie bitte die folgende Tabelle aus.

Position Aminosäure im Modell mutiert zu

1 Alanin Lysin

3 Alanin

Bitte schicken Sie ihre Lösungen an  petersen@zbh.uni-hamburg.de bis zum  2.12.2018.

Verwenden Sie als Dateinamen und Betreff GST2018_VornameNachname_4 mit ihrem

Namen und der entsprechenden Dateiendung im Dateinamen.
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